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Kapitola 3
Editácia Geometrie

Pred editáciou…

– Je potrebné pripojenie do dátového skladu pre čítanie aj 

zapisovanie “Read-Write”.

• Access

• MS SQL

• Oracle

– Objekty (cesty, toky, budovy, etc.) musia byť uložené ako 

tabuľky priestorovej databázy.  

– Tabuľky grafických objektov (triedy objektov) obsahujú 

geometriu (graphics) ako atribút každého záznamu (instance).

– Geometria je uložená ako hodnoty x, y a z.

Súradnicové systémy

– Súradnicový systém úložiska triedy objektov:

• Warehouse > Feature Class Definition.

• Nemôže byť zmenený ak sú v tabuľke triedy objektov nejaké 

záznamy. 

• Je priradený počas tvorby tabuľky. 

– Súradnicový systém  pracovného prostredia:

• View > GeoWorkspace Coordinate System

• Môže byť zmenený kedykoľvek.

• Je vhodné ak je zhodný so súradnicovým systémom objektu, ktorý 

je editovaný.
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Začiatok práce s grafickými dátami

– Vložené alebo editované grafické dáta idú cez dve transformácie 

súradnicového systému.

• Do dátového skladu (warehouse) pre ukladanie.

• Naspať do pracovného prostredia “GeoWorkspace”.

– Zabezpečte aby sa súradnicové systémy pracovného prostredia 

(GeoWorkspace) a triedy objektov (Feature Class) zhodovali. 

– Návrh riešenia:

• Použite Warehouse > Feature Class Definition pre uloženie 

súradnicového systému objektov do súboru .csf

• Použite View > GeoWorkspace Coordinate System pre načítanie 

.csf a zosynchronizovanie oboch súradnicových systémov.   
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Všeobecné poznámky k editácii

– Zatvorenie pracovného prostredia (GeoWorkspace) bez uloženia 

nespôsobuje stratu editovaných zmien.  

– Editované zmeny prebiehajú okamžite v čase (notifikácia).

– Edit > Undo

• Použite Tools > Options, Placement a Editing pre nastavenie počtu 

krokov späť (Undo)

– Možnosť vytvorenia zálohy pomocou: 

• Warehouse > Import

• Warehouse > Output do Feature Class

• Vytvorte kópiu databázy pomocou “Copy”
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Všeobecné poznámky k editácii

– Ak chcete vymazať dopyty z legendy pred editáciou, môžete 

uložiť legendu ako pomenovanú, alebo môžete nastaviť dopyty 

ako kategóriu.

• Automatická aktualizácia môže spomaliť proces. 

• Notifikácia o automatickej aktualizácii: Queries automatically 

update. 

• Notifikácia sa objaví keď je editovaná alebo vložená geometria. 

– príkaz “Geometry Editing” môže fungovať na mierne odlišných 

princípoch v závislosti do typu editovanej geometrie: 

• Bod

• Línia

• Plocha

• Text

• Obraz
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Vyberte Predmet, potom Akciu alebo Príkaz

– Najprv vyberte grafiku, potom vyberte príkaz. 

– Výber (tvorba zostáv výberu)

• Použite nástroj Select 

– Kliknite na editovanú geometriu 

– Použite  <CTRL> pre výber viacerých geometrií. 

– Kliknite a Potiahnite pre ohraničenie:

» vnútorné (Inside)

» prekryt (Overlap)

• vyberte vstupy a použite Edit > Select by Legend Entry

• použite dátové okno (podporuje výber pomocou kláves <CNTRL> 

alebo <SHIFT> )
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Zoradenie dát v dátovom okne

– Zvoľte si želané priblíženie 

pre editáciu v  mapovom 

okne 

– Použite príkaz “Window > 

Map Window Properties”

– Použite dátové okno pre 

zoradenie zobrazovania 

záznamov. 

Vybrané položky sú vycentrované pri 
použití v danom priblížení. 

Vyhýbajte sa posúvaniu mapového 
okna počas výberu/editácie v tom 
istom mapovom okne. Okno sa 
posunie iba keď sú vybrané položky 
v iných oknách. 

Informácie o geometrii “Geometry Information”

– Pracovný postup

• Vyberte geometriu 

• Pravým klikom vyvolajte ponuku a vyberte “Geometry Information”

– Pre všetky typy geometrie a všetky príslušné komponenty: 

• Polygón 

• Línie 

• Body 

• Text
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Dialógové okno: Geometry Information 
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Formát spôsobu zobrazenia súradníc: 

View > GeoWorkspace Coordinate System

Tab. Units a Formats

Ďalšie použitie nástroja “Geometry Information”

– Užitočné pri hľadaní problematickej geometrie. 

– Zmazanie vertexov

• Vysvieťte bod a pravým tlačidlom myše zmažte, alebo použite 

klávesu “Delete”

• Môže byť použité pre vymazanie prázdnych miest 

– Obrátenie vertexov v požadovanom poradí pre lineárnu 

geometriu 

• Označte začiatočný vertex línie a pravým tlačidlom vyberte príkaz 

“Reverse”

– Posuňte alebo zoraďte vertexy

• Možné iba pre geometriu s: 

– Viacerými otvormi 

– Viacerými tvarmi  (kolekcia geometrie)
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Mapové kompozície

– Línie a oblasti môžu spolu tvoriť kompozíciu. 

– Kompozícia obsahuje viac ako jeden príklad typu geometrie.  

(podobne ako komplexné prvky v MicroStation)
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Zjednodušenie kompozícií

– Kompozície sú zvyčajne výsledkom komplexných grafických 

výstupov z dátových zdrojov typu CAD alebo MGE.

– V kompozíciách nie je žiadúce: 

• Náročnejšia editácia geometrie  

• Neefektívna veľkosť geometrie z hľadiska nárokov na úložisko

– Geometria môže byť zjednodušená pomocou Analysis > 

Functional Attributes ALEBO Edit > Update Attributes

• Funkcia:

– COMPRESS (geometriu)

» Kde (geometria) je meno vstupného atribútu obsiahnutého v geometrii, ktorý 

má byť komprimovaný.  
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Pred kompresiou, po kompresii 
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“Snapovanie” vektoru

– Snapovanie (priťahovanie koncových bodov) vektoru môže byť 

povolené / zakázané poľa potreby. 

– Ak klikneme na koncový bod vektoru v období keď je viditeľný 

symbol vertexu, sú koncové body k sebe pritiahnuté. 

– Nastavenia snapovania: 
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Panel “Placement and Editing Option”
Tlačidlo “Maintain Coincidence”

– Maintain Coincidence

• Zabezpečí aby nová alebo editovaná geometria bola pritiahnutá k 

exitujúcej geometrie, nový vertex je vložený do existujúcich dát. 

• Je obvyklé nechať túto funkciu zapnutú, takže nové a editované 

dáta zdieľajú vertex na dotyčnici. 
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Panel “Placement and Editing Option”
Tlačidlo “Break Linear Features”

– Tlačidlo zabezpečuje zalamovanie nových línií pri prieniku s 

existujúcimi líniami. 

– Zalomené môžu byť iba línie. 

– Je prednastavené, aby iba línie tej istej triedy objektov boli 

zalomené. 

• Pozrite tiež: Tools > Options, Placement a Editing tab.

– Atribúty sú skopírované do nového objektu. 
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Panel “Placement and Editing Option”: 
Tlačidlo “Use Existing Geometry When Digitizing”

– Umožní použitie existujúceho grafického objektu pre digitalizáciu 

nového objektu, bez potreby “prekresliť” existujúcu časť nad 

geometriou. 

– Všeobecná postupnosť krokov:

• Zdigitalizujte oblasť existujúcej geometrie. 

• Pripojte nový objekt k existujúcej geometrii. 

• Umiestnite bod niekde inde pozdĺž existujúcej geometrie. 

• Zdigitalizujte oblasť mimo existujúcej geometrie. 
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Použitie záznamov existujúcej geometrie I.

– Objekt musí byť lokalizovateľný. 

– Musí byť spojený s vektorovými “snapmi”. 

– Nemôže “odskočiť” cez prienik. 

• Kliknite na prieniky na prekríženie

– Ak pracujete so zalomenými líniami, ale nevidíte zalomenia: 

• Skúste použiť Analysis > Analytical Merge pre spojenie línií na 

dotyčnici. 
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Použitie záznamov existujúcej geometrie II.

– Tlačidlo <Tab> môže byť použite pre “pohyb do inej strany”.

• Predvolený režim je najkratší smer. 

• <Tab> prepína medzi módom najkratšej a najdlhšej cesty. 

– Pri práci s veľmi veľkou vrstvou geometrie môže byť spomalený 

reakčný čas. 

• Skúste použiť funkciu „Use Existing Geometry“, potom kliknite 

pravým tlačidlom myši a kliknite na možnosť: Use Existing

• “Use existing” neukazuje zvýraznený smer a tak šetrí čas 

spracovania. 
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Príkaz: Edit Geometry

– Pracovný postup:

• Použite „Select Tool“ pre výber geometrie

• Edit > Geometry > Edit

• Vertexy (body prichytenia) sú znázornené čiernymi štvorčekmi. 
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Výber vertexov

– Vertexy sú po výbere a uchopení myšou sfarbené do fialova. 

• <CTRL> a <SHIFT> môže byť použité pre výber viacerých vertexov 

naraz. 

• Pozn.: Poradie výberu pomocou klávesy <SHIFT> má význam. 

• Výber jedného vertexu, nasledovaný [ <CTRL> a ] vyberie všetky 

vertexy. 

• Vybrané koncové body sú označené ako fialový trojuholník, všetky 

ostatné body sú fialové krúžky alebo bodky. 

– Označenie jedného alebo viacerých vertexov umožňuje 

nasledujúce akcie:

• Move, Add, Delete, Edit Height
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Výber vertexov

– Vertexy sú po výbere a uchopení myšou sfarbené do fialova. 
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Tlačidlá: Maintain Coincidence a Edit Geometry

– Pri používaní funkcie “Edit Geometry” a editácii zdieľaného 

vertexu:

• Možnosť “Maitain Coincidence” povolená: 

– Obidve geometrie sú editované spolu.

– Obidve geometrie budú vysvietené. 

• Možnosť “Maitain Coincidence” zakázaná:

– Iba vybraná geometria je editovaná. 

– Vertexy ktoré sú zhodné môžu byť “oddelené”. 

24
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Funkcia: Maintain Coincidence

– Ak je povolená pri ditigalizácii funkcia “Maintain Coincidence” 

(tlačidlo zatlačené a šedé):

• Geometrie, ktoré majú spoločný vertex sú editované spoločne, keď 

je tento spoločný vertex editovaný.

• Keď je vertex pridaný do zdieľanej geometrie, obidve geometrie 

zdieľajú pridaný vertex.

– Funkcia môže byť zapnutá/vypnutá podľa potreby. 

– Je obviklé nechať funkciu zapnutú. 
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Použitie: „Edit Geometry“ pre posun vertexov

– Posun vertexov

• Kliknite a potiahnite vertex do novej pozície. 

• Vysvieťte vertex a pomocou klávesnice zadajte presné súradnice 

bodu. 
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Súradnicový formát Pole pre vloženie súradníc 

Pri vkladaní súradníc sa uistite, že je 

zaškrtnuté iba jedno pole.

Nastavte projekciu 

pomocou View > 

GeoWorkspace Coordinate 

System, Units a Formats.

Použitie Edit Geometry pre pridanie alebo odobranie 
vertexov

– Pridávanie vetexov

• Jednoduchým klikom pridajte nové vetexy

– Zmazanie vertexov

• Vysvieťte vertex(y), ktoré chcete zmazať a zmažte ich pomocou 

klávesy “Delete” alebo zvoľte “del” po pravom klinutí myše. 

• Pozn.: Nie je možné zmazať vertex ak by to mohlo zmeniť typ 

geometrie. 

– Línia musí mať dva body. 

– Area musí mať tri body. (4 uložené súradnice)

27
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Použitie Edit Geometry pre upravenie výšky

– Vysvieťte vertex(y) a pravým tlačidlom myše vyberte možnosť 

“Edit Height”.

– Jednotka výšky “Height Unit” (m, ft, etc. ) môže byť nastavená: 

View > GeoWorkspace Coordinate System, Units a Formats.

– Nastavenie prednastavenej výšky: Tools > Options, Placement 

and Editing tab.

– View > Default Height zobrazí dialógové okno. 

– Keď je vertex posunutý alebo pridaný pomocou Edit > Geometry 

je mu priradená prednastavená výška. 
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Príkaz: Continue Geometry

– Povolí doplniť geometriu pre vybranú triedu. 

• Vykrajovanie “dier” vo vnútri oblastí

• Predĺženie línií

• Tvorba viacerých geometrií v rámci jedného celku (nesúvislá 

geometria)

– Príklad: Florida Keys (ostrovy) sa môžu odvolávať na jeden záznam v 

tabuľke štátnych zriadení.

– Umožňuje pridať novú geometriu do prvku, ktorý nemá zatiaľ 

žiadnu geometriu. 
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Funkcia: Continue Geometry – pracovný postup 

– Pracovný postup 

• Vyberte geometriu alebo dáta, ktoré chcete predĺžiť. 

• Aktivujte mapové okno (ak nie je aktívne)

• Vyberte Edit > Geometry > Continue

– Otvorí sa okno “Continue Geometry”

– Vyberte umiestnenie a režim editácie novej geometrie. 

– Pravým tlačidlom zatvoriť okno alebo zrušiť výber. 
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Príkaz: Redigitize Geometry

– Umožní reeditovať časť akejkoľvek oblasti alebo línie. 

– Pracovný postup :

• Vyberte objekt pre editáciu 

• Vyberte Edit > Geometry > Redigitize

• Použite myš pre výber úvodného bodu reeditácie. 

• Použite myš pre výber koncového bodu reeditácie. 

• Zahájte digitálizáciu Z ÚVODNÉHO BODU do koncového. 

– Podporuje bežné nastavenia pre digitalizáciu. 
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Príkaz: Trim Geometry

– Umožní interaktívne odstrániť (pristrihnúť) časť lineárnej 

geometrie späť 

– Časť, ktorá má byť odstránená je zvýraznená. 

– Pracovný postup :

• Vyberte Edit > Geometry > Trim

• Vyberte koncový bod línie, po ktorú má byť línia odstránená.

– Je možné špecifikovať vzdialenosť, o ktorú má byť línia 

skrátená. 
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Pristihnutie línie po priesečník
(Trim to Intersection) 

– Skráti vybranú líniu späť, po najbližší priesečník. 

– Pracovný postup :

• Vyberte Edit > Geometry > Trim to Intersection

• Umiestnite kurzor nad líniu ktorá má byť skrátená. 

– Línia bude zvýraznená. 

• Kliknite pre vykonanie akcie, alebo posuňte kurzor preč zo 

zvýraznenej línie. 

– Priesečník musí byť viditeľný v mapovom okne. 

– Objekty musia byť lokalizovateľné (položka legendy).
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Funkcia “Extend”

– Umožňuje interaktívne rozšíriť lineárnu geometriu. 

– Rozsah rozšírenia je zvýraznený. 

– Pracovný postup :

• Vyberte Edit > Geometry > Extend

• Vyberte koncový bod línie, ktorá má byť rozšírená. 

• Zadajte bod špecifikujúci rozsah rozšírenia.  

– Je možné špecifikovať vzdialenosť, o ktorú má byť objekt 

rozšírený. 
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Funkcia: Extend to Intersection

– Predĺži vybranú líniu až kým nepretne danú líniu alebo oblasť v 

mapovom okne. 

– Pracovný postup :

• Vyberte Edit > Geometry > Extend to Intersection

• Umiestnite kurzor nad líniu, ktorú chcete predĺžiť.  

– Zvýraznená oblasť predĺženia sa zobrazí. 

• Kliknite pre vykonanie akcie, alebo posuňte kurzor preč zo 

zvýraznenej línie. 

– Priesečník musí byť viditeľný v mapovom okne. 

– Objekty musia byť lokalizovateľné (položka legendy).

– V súčasnosti nepodporuje predĺženie oblúkov po priesečník 

(oblúky môžu byť manuálne predĺžené pomocou funkcie 

“extend”).
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Funkcia: Extend Two Lines to Intersection

– Dynamicky predĺži dve línie, až kým sa nepretnú. 

– Pracovný postup :

• Vyberte Edit > Geometry > Extend Two Lines to Intersection.

• Vyberte prvú líniu.

• Posuňte kurzor ponad druhú vybranú líniu. 

• Rozsah dynamického predĺženia sa zobrazí.

• Potvrďte akciu. 

– Je možné skrátiť spať jednu líniu, ale nie obe.
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Funkcia: Insert Intersection

– Vloží prienik tam, kde sa pretínajú dve nezalomené línie. 

– Pracovný postup :

• Vyberte Edit > Geometry > Insert Intersection

• Posuňte kurzor nad priesečník. 

• Priesečník sa zvýrazní. 

• Potvrďte akciu. 

– Objekty musia byť lokalizovateľné. 

– Ak objekty sú z rozdielnej triedy objektov a je potrebné ich 

zalomiť, postupujte : Tools > Options, Placement a Editing, 

Break all  features.  
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Funkcia: Move Geometry

– Posunie vybrané položky v sade.

– Pracovný postup :

• Vyberte objekt(y) ktoré chcete posunúť

– Môžu to byť rôzne triedy objektov 

• Vyberte Edit > Geometry > Move

– Dáta sú overené a všetky body prichytenia sú zobrazené. 

• Zadajte pôvodný bod. 

• Zadajte požadovanú cieľovú lokalizáciu.

– Podporuje presné zadanie XY pomocou klávesnice a 

snapovanie vertexov. 

– Funkcia “Move Geometry” je pomalšia ako funkcia “Copy 

geometry”.
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Funkcia: Spin 

– Použite funkciu Spin pre rotáciu bodov a textu okolo ich 

vlastných pôvodných bodov. 

– Pracovný postup :

• Vyberte jednu alebo viac bodových vrstiev.

• Vyberte Edit > Geometry > Spin

– Pôvodné príchytky sú zobrazené.

• Prejdite kurzorom ponad geometriu.

– Objaví sa symbol funkcie “Spin”.

• Kliknite na vybraný bod pre prichytenie a otočte body pomocou 

pohybovania kurzorom.

• Potvrďte akciu/ esc pre zrušenie akcie. 

39
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Funkcia: Rotate Geometry

– Interaktívne otočí jednu alebo viac objektov okolo bodu 

zadefinovaného používateľom..

– Pracovný postup :

• Vyberte jednu alebo viac objektov vo vybranej zložke. 

• Vyberte Edit > Geometry > Rotate

• Určte základný bod otáčania.

• Použite kurzor pre dynamické otáčanie. 

• Potvrďte akciu/ esc pre zrušenie akcie. 
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Funkcia: Split Feature

– Umožňuje rozdelenie jedného alebo viacerých objektov a 

kopírovanie vlastností do nových objektov. 

– Pracovný postup :

• Vyberte objekt(y). 

• Vyberte Edit > Feature > Split

• Vyberte metódu rozdelenia.

• Digitalizujte rozdelený bod, líniu alebo polugón. 
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Poznámky k funkcii “split” (rozdelenie) I. 

– Je jednoduchšie, ak objekty ktoré sú rozdeľované majú primárny 

kľúč definovaný ako “AutoNumber”. 

– Môžete vypnúť nastavenie “Display Properties”.

– Podporuje:

• Rozdelenie zbierky geometrie (napr. ostrovy) s použitím nastavenia 

“split by area”.
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Ukážka rozdelenia polygónov: 
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Poznámky k funkcii “split”(rozdelenie) II. 

– Funkcia “Split Feature” taktiež podporuje:

• Presné zadanie pomocou kláves

– Príklady:

» Vzdialenosť,Orientácia

» Vzdialenosť,Azimut

• Použitie existujúcej geometrie

– Niekedy je užitočné najprv líniu nakresliť až potom rozdeliť. 

– Niekedy je komplikované pracovať s veľmi veľkými objektami.  

Teoretické uľahčenie práce:

• Rozdeliť veľmi veľké objekty. 

• Po práci ich naspäť spojiť pomocou funkcie “Merge Feature”. 

(pozrite si kapitolu “Merge Feature”).
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Funkcia: “Merge Feature”

– Umožňuje spojenie jedného alebo viacerých objektov do 

jedného. 

– Podporuje všetky typy geometrie okrem obrázku.

– Objekty, ktoré majú byť spojené musia byť tej istej triedy 

objektov.  (napr. parcely alebo ulice)

– Všetky geometrie sú skopírované do prvého vybraného 

záznamu a následne sú vymazané všetky ostatné záznamy. 
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Funkcia “Merge Features” - pracovný postup

– Vyberte prvý objekt . 

• Všetky atribúty prvého objektu budú skopírované do novej 

geometrie. 

– Použite <Shift> a/alebo <Ctrl> na vyznačenie ostatných 

objektov, ktoré majú byť spojené. 

• Atribúty týchto objektov budú zmazané a ich geometria bude 

spojená so prvým vybraným objektom. 

– Pozn.: Objekty musia byť z tej istej triedy objektov. 

– Vyberte Edit > Feature > Merge.

45
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Funkcia: “Copy Feature”

– Skopíruje vybrané objekty. 

– Pracovný postup :

• Vyberte objekty, ktoré chcete skopírovať. 

• Vyberte Edit > Feature > Copy

– Vertexy sú zobrazené.

• Definujte zdrojový bod. 

• Definujte cieľový bod. 

– Vybrané položky sú skopírované do nových záznamov. 
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Funkcia: Delete Feature

– Vymaže vybrané objekty. 

– Vymazanie môže byť vrátené späť pomocou tlačidla “Undo” v 

aktívnom okne pracovného prostredia. 

• Pozrite tiež: Tools > Options, Edit a Placement tab, nastavenia 

Undo.

– Pracovný postup :

• Vyberte objekty.

• Vyberte Edit > Feature > Delete

– Objaví sa dialógové okno pre potvrdenie.

– Dialogové okno je nepovinné (pozrite tiež: Tools > Options, Edit a 

nastavenia Placement tab).

– Vyberte “Yes” pre zmazanie vybraných objektov, alebo zrušte 

akciu pomocou “Cancel”.

47

Funkcia: Delete Geometry

– Vymaže geometrický objekt (grafický) vybraného prvku

– Záznam v databáze nie je vymazaný. 

– Pracovný postup :

• Vyberte feature(s)

• Vyberte Edit > Geometry > Delete Geometry

• Vyberte Yes or Cancel on the confirmation dialog.

– New Geometry can be added to the record using Continue 

Geometry.

• See Continue Geometry workflow slide (previous).
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Partial Delete (čiastočné vymazanie)

– Vymaže časť lineárnej geometrie. 

– Pracovný postup:

• Vyberte líniu pre editovanie. 

• Edit > Geometry > Partial Delete

• Zvoľte začiatočný bod pre čiastočné vymazanie. 

• Zvoľte koncový bod pre čiastočné vymazanie

– Pozn.: Začiatočný a koncový bod musia byť na tej istej línii. 

49

Konštrukcia „Circular Fillet“ (kruhových zaoblení)

– Kruhové zaoblenia (oblúky) medzi dvomi neparalelnými 

geometrickými segmentami, ktoré sú časťou línie, alebo 

areálového prvku.

– Postup:

• Vybrať Edit > Geometry > Construct Circular Fillet.

– Objaví sa ovládací panel funkcie.

– Ľubovoľne zvoľte triedu prvkov na ovládacom paneli.

– Ľubovoľne zvoľte možnosti Lock (uzamknutie) a Trim excess 

(orezávanie prebytkov)

• Zvoľte prvý a druhý segment.

50

Použitie Construction Aids (konštrukčnej pomoci)

– Príkazy Insert Feature, Continue 

Feature, Redigitize,  Split Feature a 

Edit Geometry teraz obsahuje 

použitie Constructions Aids.

– Poskytuje možnosť stavby geometrie 

pomocou špecifických metód a ich 

použitie počas umiestňovania, alebo 

editovania bez prerušenia príkazu.

– Veľa možností z Construction Aids 

sú dostupné z menu po kliknutí 

pravým tlačidlom myši (Right Mouse 

Click), počas digitalizácie.
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Použitie Right Mouse Click pre bodové prvky

– Pri vkladaní bodového prvku, ako napríklad mesto, alebo most, 

kliknutie pravým tlačidlom myši ponúkne možnosti menu 

zobrazeného nižšie.

52

Použitie Right Mouse Click pre líniové prvky

– Pri vkladaní líniového prvku, ako napríklad cesta, alebo rieka, 

kliknutie pravým tlačidlom myši ponúkne možnosti menu 

zobrazeného nižšie.

53

Použitie Right Mouse Click pre areálové prvky

– Pri vkladaní areálového prvku, ako napríklad jazero, alebo štát, 

kliknutie pravým tlačidlom myši ponúkne možnosti menu 

zobrazeného nižšie.
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X a Y

– Počas príkazu umiestnenia/editácie, príkaz X,Y umožňuje 

umiestniť hodnoty na osi X smerované na východ a osi Y 

smerované na sever (prípadne dĺžka a šírka) a zhotoviť tak bod 

na stanovenej pozícií (X, Y).

55

DeltaX a DeltaY

– Počas príkazu umiestnenia/editácie, Delta X a Delta Y zostrojí 

bod v stanovenej vzdialenosti v horizontálnom a vertikálnom 

smere od posledného zostrojeného bodu.

56

DeltaX, DeltaY from Point (DeltaX and DeltaY od bodu)

– Počas príkazu umiestnenia/editácie, Delta X, Delta Y from Point 

zostrojí bod na stanovenej vzdialenosti v horizontálnom a 

vertikálnom smere od označenej polohy.
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Distance and Direction from Point (vzdialenosť a smer 
od bodu)

– Počas príkazu umiestnenia/editácie, the Distance and Direction 

from Point zostrojí bod stanovenou vzdialenosťou a smerom od 

označenej polohy.

58

Distance Along Feature (vzdialenosť pozdĺž prvku)

– Distance Along Feature umožňuje použiť relatívne umiestnenie, 

keď je známa poloha ďalšieho bodu len na základe jeho vzťahu 

s iným bodom.

– Je potrebné zadať vzdialenosť v paneli nástrojov Distance Along 

Feature, následne je potrebné označiť začiatočný bod, z ktorého 

bude ďalší bod vyrovnaný.

59

Distance/Distance Intersection
(vzdialenosť/vzdialenosť prienik)

– Počas príkazu umiestnenia/editácie, Distance/Distance 

Intersection vytvorí bod na prieniku stanovenej vzdialenosti od 

dvoch rozličných polôh. 
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Bearing/Bearing Intersection
(prienik orientovaných smerníkov)

– Počas príkazu umiestnenia, Bearing/Bearing Intersection 

skonštruuje bod na prieniku 2 línií, definovaných cez stanovený 

smer orientovaného smerníka z dvoch rôznych polôh.

61

Deflection Angle (vychýlenie uhla)

– Deflection Angle umožní zadať uhol do 

vyskakovacieho okna v paneli nástrojov.

– Construction aid obmedzuje dynamickú 

polohu kurzoru na samotné vychýlenie uhla 

relatívne k poslednej línií segmentu.

– Konštrukčná pomoc je k dispozícií, keď je 

zdigitalizováná aspoň línia segmentu. Uhol 

musí byť medzi -360 a 360 stupňov (alebo 

v ekvivalente aktuálnej jednotky), vrátane.

62

Azimuth (azimut)

– Azimuth umožňuje obmedziť umiestnenie na absolútny 

azimutálny uhol pre rovinnú a priestorovú geometriu.
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Bearing (orientovaný smerník)

– Bearing umožňuje obmedziť umiestnenie na absolútny smerový 

uhol pre rovinnú a priestorovú geometriu.

64

Parallel To (paralelne na..)

– Parallel To umožňuje skonštruovať bod, ktorý leží na segmente 

začínajúcom z posledného zameraného bodu a je rovnobežný s 

daným prvkom, prípadne na dotyčnicu v bode, kde bol prvok 

vybraný  v prípade, že ide o oblúkovú geometriu.

65

Perpendicular To (kolmo na..)

– Perpendicular To umožňuje určiť ďalší 

segment prvku kolmo na iný prvok.

– Na základe výberu tohto módu je 

používateľ vyzvaný na vyznačenie 

nebodového prvku, ku ktorému bude 

konštruovaná kolmosť.

– Tak isto je možné určiť miesto ďalšieho 

segmentu na oblúku kolmo na dotyčnicu 

v dotykovom bode.
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Perpendicular From (kolmo z..)

– Perpendicular From umožňuje určiť ďalší 

segment prvku kolmo z iného prvku.

– Táto pomôcka je prístupná iba ak je 

posledný vertex práve prichytený k 

nebodovému prvku.

– Je taktiež možné prichytiť sa k oblúku pri 

umiestnení ďalšieho segmentu kolmo z 

dotyčnice na oblúk v dotykovom bode.

67

Orthogonal (pravouhlý)

– Orthogonal umožňuje určiť líniový 

segment, ktorý je kolmý na predošlý 

segment.

– Koncový bod kolmého segmentu je 

zobrazený dynamicky v mapovom okne 

počas pohybov kurzorom, na 

vyjadrenie danej polohy. 

68

Close Orthogonal (spojitá pravouhlosť)

– Close Orthogonal umožňuje vložiť prvok 

cez spájanie. Geometria je určená 

tvorbou posledného segmentu kolmo na 

prvý, čo môže byť orezané, alebo 

rozšírené na uzavretie geometrie daného 

segmentu.

– Orezaný, prípadne rozšírený diel z 

prvého segmentu, tak ako aj plánovaná 

línia od posledného bodu do prvého 

segmentu projektovanej geometrie, sú 

ťahané do miesta, ktoré sa môžu 

predĺžiť, alebo skrátiť vložením 

pravouhlej operácie pred potvrdením 

kroku.
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Use Existing (použiť existujúce)

– Use Existing umožňuje určiť ďalší segment prvku použitím už 

existujúcej geometrie.

70

Use Existing konštrukčná pomoc odlišná od použitia
Existing Geometry When Digitizing

– Táto konštrukčná pomoc sa odlišuje od možnosti Use existing 

geometry when digitizing v možnostiach Placement and Editing, 

prípadne Options toolbar v dvoch podstatných veciach: 

• Construction aid je aktívna len pre umiestnenie nasledujúceho 

vertexu potom, ako je vrátený predchádzajúci mód umiestnenia. 

Keď je voľba zapnutá, aplikuje sa na každý pripojený vertex po 

dobu jej zapnutia. Je potrebné voľbu vypnúť pre zrušenie jej efektu.

• Možnosť Use existing geometry when digitizing zvýrazňuje 

geometriu medzi posledný vertexom a dotykovým bodom kurzora 

pri každom pohybe myšou, čo spôsobuje značné spomalenie 

zobrazenia pri geometrií obsahujúcej viacero vrcholov. Mód 

dočasnej pozície zvýrazňuje geometriu medzi prvým a druhým 

bodom jeden krát (v momente umiestnenia druhého bodu). Tá 

zostane zvýraznená, pokiaľ nie je vložený tretí dátový bod na 

potvrednie geometrie. To umožňuje kurzoru pohyb bez spomalenia 

zobrazenia.

71

Offset

– Offset umožňuje umiestniť prvok v určitej vzdialenosti od iného 

prvku.

– Offset umiestni dočasný prvok vo

– vzdialenosti stanovenej v paneli funkcie Offset 

– ovládaním z užívateľom vybraného prvku

72
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Arc Tangency Constraint  
(ohraničenie dotyčnice na oblúk)

– The Arc Tangency Constraint je položka v menu, ktorá po 

odškrtnutí indikuje, že dotyčnica na oblúk je aktívna.

73

Segment Length Constraint
(ohraničenie dĺžky segmentu)

– Segment Length Constraint je položka 

v menu, ktorá po zapnutí zobrazí 

dialógové okno, umožňujúce vložiť 

hodnotu na ohraničenie dĺžky 

segmentu od miesta začiatku.

74

Edit Text (editovanie textu)

– Umožňuje editovať obsah textu, umiestnenie a ostatné vlastnosti 

textu: typ písma, veľkosť, tučnosť písma, rozmer, podčiarknutie, 

sklon. 

– Postup:

• Vyznačte časť textu na editáciu.

• Zvoľte Edit > Edit Text.

– Objaví sa diaógové okno Edit Text.

• Urobte zmeny vlastností textu a stlačte OK.
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Edit Text Dialog (dialógové okno editovania textu)

– Podporuje editovanie položiek viacnásobného textu naraz. 

– Style override(prepis štýlu) uchováva štýl textu (veľkosť, farbu, 

atď..) v geometrií textu, takže štýl môže byť predvolený pre 

všetkých používateľov a GeoWorkspaces.

76

Editovanie geometrie s Functional Attributes (logické 
atribúty)

77

Functional Attributes (FA) 
Spin Function (funkcia otáčania)

– Functional Attributes obsahujú geometriu otáčania funkcie, ktorá 

umožňuje stočiť bod orientovanej geometrie na pevnú hodnotu, 

alebo atribút.

– Formát: SPIN(Input.Geometry,Angle)

– Príklad:

• Užívateľom definovaná hodnota uhla

– SPIN(Input.Geometry1,45)

• Atribútovo definovaná hodnota uhla

– SPIN(Input.PointGeometry,input.offsetangle)

– Poznámka: offsetangle je atribút bodového prvku typu čísla.
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Spin Function vzhľadom na FA

– Výsledkom je dopyt prvku.

– Warehouse > Output to Feature Class môže byť použité na 

výstup dopytu do novej triedy prvkov.

– Nová trieda prvkov bude mať dve geometrie (primárnu a 

sekundárnu).

– Ak je nežiadúca, sekundárna geometria môže byť odstránená:

• Použitím FClass Definition sa odskúša pridelená súradnicová 

sústava novej triedy prvkov

• Použitím Database Utilities sa vymaže tabuľka metadát.

• Vstup do databázy a vymazanie stĺpca sekundárnej geometrie..

• použitie Database Utilities na vloženie tabuľky metadát prideleného 

súradnicového systému ako je popísane v kroku 1.
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